Expression Pedal Vibrates

Get help from other SoftStep users.
mehrdadp
Posts: 18
Joined: Sun Jun 03, 2012 1:34 pm

Expression Pedal Vibrates

Postby mehrdadp » Fri May 29, 2015 10:06 pm

I have M-Audio EX-P expression pedal connected to Softstep. I have calibrated it and it works fine until floor the pedal down all the way. Pedal continuously sends midi messages to DAW when pedal is at floor position. I monitored the midi messages as cc messages between values of 6 to 10. The pedal keep sending this vibrating message constantly when the pedal is floored. However, midi messages stop vibrating once the pedal is left open a little bit. Does anyone know what causes constant flow of vibrating cc midi messages when The expression pedal is floored? Thanks.
MacBook pro, OS 10.10.5, Apple Duet, Ableton Live 9, SoftStep 1 in hosted mode, Amplitube 4.
emmett@KMI
Posts: 121
Joined: Tue Apr 29, 2014 1:00 pm

Re: Expression Pedal Vibrates

Postby emmett@KMI » Mon Jun 01, 2015 2:32 pm

It seems to me like it was a calibration error or a modline adjustment. One important thing when using an expression pedal with your SoftStep is to go to your editor and in the settings tab, hit reset sensitivity and then hit send. Otherwise your pedal data will be distorted.

Next make sure you have only one pedal modline in your preset and that it's modline has has default settings. After you recalibrate, do you still have the CC error?
unguitar
Posts: 50
Joined: Sat Apr 13, 2013 2:16 pm

Re: Expression Pedal Vibrates

Postby unguitar » Mon Aug 03, 2015 10:39 am

Same issue here.
I think that this problem may be noticeable just under certain specific circumstances as the vibration is very subtle.

In my case this is making the pedal useless, in fact it is used to control the same parameter ( a volume fader) that i am controlling via a hand controller.
I need to be able to act on it sometimes with a foot pedal, sometimes with a finger: therefore i have Two different controllers sending the same midivalues.
The footcontroller on the softstep is impossible to use like this as these vibrations are keeping the parameter modulation always active, bringing its value to the centre of the vibration.

Hope this makes sense.

Calibration doesn't fix it.
Different pedals don't fix it, they work fine on other usb ( logidy) or hardware controllers ( novation, gordius, rfx) or hardware processors ( eventide, tc).
It looks like the cc input is too sensitive.

What a pity.

But nice piece of hardware, beside that.
My best,
Luca
emmett@KMI
Posts: 121
Joined: Tue Apr 29, 2014 1:00 pm

Re: Expression Pedal Vibrates

Postby emmett@KMI » Wed Aug 05, 2015 11:29 am

Can you list the settings in your pedal modline? Also make sure there is only one pedal modline in your whole preset.

I've seen that problem pop up with non-default pedal settings such as having a smoothing value greater than zero.
unguitar
Posts: 50
Joined: Sat Apr 13, 2013 2:16 pm

Re: Expression Pedal Vibrates

Postby unguitar » Wed Aug 05, 2015 12:03 pm

thank you Emmet,
hope it is like that but I cannot check it right now.
will certainly do as soon as I'll be back to the studio, five days from now...
unguitar
Posts: 50
Joined: Sat Apr 13, 2013 2:16 pm

Re: Expression Pedal Vibrates

Postby unguitar » Thu Aug 13, 2015 1:58 pm

Here are the details:
I have the pedal set to control the same parameters.
The first key of each preset ( in old school i would call it bank) contains the pedal as a source, with the following values ( when not mentioned = blank/inactive):
Source : pedal
Gain: 1,00
Offset: 0
Table: linear
Min: 0
Max: 127
Smooth: 0
Message type: cc
Cc#: 121
Ch: 7
Output port: sscomport1

I tried to reset the pedal many other times with no success.

I would be happy to know there's a solution !

Thanks,
Luca

Return to “SoftStep Users' Help Exchange”

Who is online

Users browsing this forum: No registered users and 2 guests

cron