Looping LED Feedback in Live

Get help from other SoftStep users.
fiddleguy
Posts: 1
Joined: Mon Jun 13, 2016 8:27 am

Looping LED Feedback in Live

Postby fiddleguy » Mon Jun 13, 2016 8:47 am

I'm trying to get the LED's on my Softstep 2 to correspond to the looper in a somewhat similar way to this https://www.keithmcmillen.com/blog/loop ... -feedback/

Being a total Max4Live noob (in fact a noob at Any type of coding) i've been struggling through it. What i'd ultimately like to have is this kind of setup for 4 loopers in tracks 1-4
Looper Empty: No LED
Record and Overdub: (Slow) Blinking Red
Playing: Solid Green
Stopped: Blinking Green

In addition, I need these to hold true only when the preset named "Loop" is active as I have several other presets that control other parts of live. I've tried accomplishing this without M4L by just using the advanced editor however sometimes the LED's will get out of sync with the looper.

If anyone could help or point me in the right direction it would be much appreciated!
TheOtherSupport@KMI
Posts: 649
Joined: Fri Jan 31, 2014 5:31 pm

Re: Looping LED Feedback in Live

Postby TheOtherSupport@KMI » Mon Jun 13, 2016 9:20 am

Yeah unless you are using the state of the Looper in Live to control the LEDs they will get out of sync.
Like the blog post says, you'll have to further defines cases for each of the states and then send the appropriate MIDI values to the SS.
The post gives you the info necessary to almost setup what you describe, there is no distinction between an empty and a stopped looper, so that won't be possible. Unless I know what you've done, and what isn't working, I can't help much.

In order to only have the LEDs reflect the looper on a particular preset takes a bit of work, so you should think about that after you've gotten the basic LED behavior going.

Return to “SoftStep Users' Help Exchange”

Who is online

Users browsing this forum: No registered users and 3 guests