SoftStep locks up after awhile

Get help from other SoftStep users.
Posts: 62
Joined: Sat Apr 16, 2011 2:11 am

SoftStep locks up after awhile

Postby adamqlw » Wed Oct 26, 2011 4:41 pm

Hi guys,

I am having this issue again with my SoftStep, at my wits end to figure out what exactly is causing it as I need to rely on the SoftStep live...

I have noticed that my SoftStep is sensitive to which USB port I plug in to, it only seems to work with one particular port on my laptop so I always use that one. This also applies to my Eleven Rack, plugging it into other ports changes the name of the MIDI port which messes with my SoftStep presets. No biggie, I just always use the same ports for the SoftStep and the Eleven Rack. This was working perfectly for the last 3 months (twice weekly use, several hours), but suddenly last night the SoftStep just failed to respond again after a few minutes of use. The only way to get it up and running again was to shut the editor, unplug the SoftStep, plug it in again, and then it worked for another 10 mins or so.

I have verified that there are no open program sending MIDI messages to the SoftStep, and am using LoopBe to route the SoftStep to Guitar Rig. I need this for live as I use to SoftStep to control both patch changes and my looper. Has anybody has a similar experience where the SoftStep hangs after some use and managed to fix it?
Posts: 53
Joined: Wed Feb 02, 2011 7:51 am

Re: SoftStep locks up after awhile

Postby mrgorilla » Wed Feb 15, 2012 1:34 pm

I've been having this issue a lot lately (i.e. hook everything up, open the editor and the editor doesn't detect any pressure or touch from the softstep).. sometimes I have to unplug, re plug in, quit, un plug, re plug over and over again to get the issue to go away.

Anyone figure this bug out?
Posts: 62
Joined: Sat Apr 16, 2011 2:11 am

Re: SoftStep locks up after awhile

Postby adamqlw » Sat Feb 18, 2012 9:13 am

I did a few things and finally it worked. I'm not sure what precisely was the correct step, but the combination has it working alright (for now). I am giving up on the SoftStep editor (at least on my laptop) though, and biting the bullet to get the MIDI expander.

In any case, try the following:

If you are using a laptop, set your monitor to never turn off.
Turn off any USB sleep mode settings in your power configuration.
Try a different USB port. Once you find one that works, stick with it.

I suspect the reason is certain USB ports on my laptop aren't providing enough juice to the SoftStep, or that when the monitors powers down and back up there is a dip on the current supplied to the SoftStep. Either way, I suspect it's an issue of the SoftStep continuously receiving sufficient power. Although this is all conjecture, considering nobody from KMI has replied to this post which is now over 3 months old...

Good luck.
Otis Scarecroe
Posts: 64
Joined: Mon Jan 31, 2011 2:18 pm

Re: SoftStep locks up after awhile

Postby Otis Scarecroe » Sat Feb 18, 2012 3:22 pm

Have you contacted KMI Support directly and received no reply?

They have made it clear that this forum exchange is for "users" to exchange info only, with an occasional
response from KMI techs. See: viewtopic.php?f=10&t=247

It's probably a good idea to keep poking at Support's home email and report any info /solutions here for general user consumption.Also, report lack of response, if any. Keeps everything on the up and up!

Posts: 40
Joined: Sat Feb 12, 2011 6:15 am

Re: SoftStep locks up after awhile

Postby ericzang » Sat Feb 25, 2012 4:05 am

I experience similar behavior - works for awhile, then software stops receiving data. I'm using Ableton 8, win7 64. I've been assuming it is Ableton's problem and perhaps having lots of midi devices active in my system, but I have not found the cause yet. I use two SS connected to my computer (2 musicians) and finally bought the midi expander and that seems to have fixed the problem for that one SS, but the other connected via USB still has disconnect issues.

I've tested before by having the SS connected for hours, yet doing nothing with the host software and it continued to work. Maybe it has something to do when the computer/host is working hard.

I'll probably wind up getting another midi expander... :-\
Posts: 62
Joined: Sat Apr 16, 2011 2:11 am

Re: SoftStep locks up after awhile

Postby adamqlw » Sun Feb 26, 2012 10:48 pm

Unfortunately for me my issue with this has also returned. Similarly, I have left it connected for hours with no activity and have no problems, but when I connect my ElevenRack and communicate with it via hosted mode, it seems to crap out on me after some time. I have tried disabling just about everything (monitor dimming, USB sleep etc.) but to no avail. I suspect that it might have been an issue with my laptop supplying consistent and stable power, but plugging a USB power adapter into the MIDI Expander port (which did provide power) did nothing to solve this problem. It's incredibly frustrating having it die on my when performing live, which has happened a couple of times. I have a MIDI Expander on backorder, I'm hoping when it arrives it solves this problem....
Posts: 62
Joined: Sat Apr 16, 2011 2:11 am

Re: SoftStep locks up after awhile

Postby adamqlw » Tue Feb 28, 2012 4:58 pm

Mildly amusing to note that a thread with any "easy" question/statement (antivirus picks up the editor) gets a reply, but a thread which suggests that three people have a fairly similar and crippling problem gets completely overlooked...
Posts: 2
Joined: Fri Mar 09, 2012 9:42 am

Re: SoftStep locks up after awhile

Postby DaveZ » Fri Mar 09, 2012 10:04 am

I think I may have found the culprit. I wasn't paying attention to which usb cable I was using for my audiobox usb and the softstep.. When using the long one that came with the softstep my audiobox wasn't detected by the macbook. Switching to a shorter cable it worked fine. I ran a test using a shorter cable for the softstep and it seemed to not lock up as well. Going back to the one that came with it, locks up in 10min or so. Switch back to a shorter cable and seemingly works as needed.

I've got my setup running right now and am testing roughly every 45min or so and so far since 9am it's been fine using a shorter cable with the softstep.

Hope that helps.

Posts: 79
Joined: Sun Aug 07, 2011 9:04 am

Re: SoftStep locks up after awhile

Postby TomSwirly » Fri Mar 09, 2012 3:10 pm

> When using the long one that came with the softstep my audiobox wasn't detected by the macbook. Switching to a shorter cable it worked fine.

That's a drag - you want the longest cable possible for performance!

So I now have some strong theories about this issue.

If you exchange a long cable for a short cable and your problem goes away, it's often an issue with noise on the line - that is, individual bits are getting flipped in transmission.

This can be particularly bad for MIDI devices, because a single bit flip can change data into a "command" (as in a note on) - and then due to "running status" you'll never get a chance to recover. Or it can change reasonable data to unreasonable data that will crash the software.

We do know that this unit is noisy in the audio fashion when the backlighting is on. It's not so unreasonable to assume that its line might be noisy too.

*** How to fix this? ***

You can deal with this on your end by getting the highest quality USB cable you can (not Monster Cable). I don't know much about USB cables, but there must be a known good brand with heavy shielding...

The firmware clearly needs to be much more robust. If I were developing this, I'd have the following criteria:

1. there should be no possible input - and by that I mean correct inputs, minorly incorrect inputs, malicious inputs, or just random crap - that could ever lock up the pedal under any circumstances or any data speed.

Clearly if you continuously flood the pedal with data beyond its ability to process, it is going to have some troubles - but you have to be able to do that and have it bounce back.

This is easy to test - you write a test harness that lets you do exhaustive testing and create a few specific tests - one with a flood of random data - one where you take a lot of real-world data and add random one-bit errors to it fairly liberally - one where you deliberately try to create malformed packets in many different ways.

2. The data flow from the computer to the footpedal should be such that *any* one bit error is corrected automatically.

I didn't just pull those numbers out of my, er, derriere, there are well-understood error correcting codes that will do this for you every time - they're called Hamming codes: and with a little more work they'll actually correct any one-bit error in your packet and detect any two-bit error (and yes, that includes errors in the check bits too... :-D)

There's a nice 72, 64 code with this property - there's one byte overhead for every eight bytes you send and it can correct one and detect two with just that - impressive!

Hamming(7,4) with a parity bit is really easy to implement and corrects any one bit error (and detects 2) in every 4-bit chunk! It does have 100% overhead but in this application, this might not be an issue - I suspect the data flow from the computer to the pedal is a tiny fraction of the possible USB rate anyway.

(oh, and yes, I could write this. I'd give you the family rate - I worked on error correction codes around 1981, can you believe, and it'd be loads of fun to do this with more than 16K of RAM and a processor with a speed much greater than 1MHz... :-D)
Posts: 62
Joined: Sat Apr 16, 2011 2:11 am

Re: SoftStep locks up after awhile

Postby adamqlw » Mon Mar 12, 2012 4:54 pm

Interesting thoughts. I will try and see if I can get my hands on a high quality shielded cable to experiment. In the mean time I bought the MIDI expander, which seems to be working fine for now.

Still hoping to see a proper and official resolution to this issue.

Return to “SoftStep Users' Help Exchange”

Who is online

Users browsing this forum: No registered users and 3 guests