SOLVED: modlines vanishing after being added

Get help from other SoftStep users.
Posts: 4
Joined: Mon Jul 17, 2017 3:52 pm

SOLVED: modlines vanishing after being added

Postby aspiers » Wed Jul 19, 2017 3:45 pm

Hi all, I'm very new to SoftStep programming, and I just something the hard way (trial and error) so I thought I'd share it here in case it helps anyone else.

When I started messing around with modlines in the advanced editor, it seemed to be impossible to simultaneously attach certain combinations of sources to a single key via multiple modlines, whereas other combinations worked fine.

For example, I managed to attach both "Foot On" and "Pedal" modlines to a key and have it working fine. But when I tried to attach "Pressure Live" and "Pedal" modlines to the same key, after switching away to another preset and back, the "Pedal" modline vanished. The same problem seemed to occur when I tried to attach both "X Live" and "Y Live" modlines to a key.

HOWEVER, after a few days I finally realised that the problem was nothing to do with the particular combination of Source Types, and simply that after clicking the plus (+) icon to add a new modline, I needed to click the number at the left-most end of the modline row in order to enable that modline, or modify one of the parameters! Without enabling it or modifying any parameter, it is not even considered as a change to the preset (the Save button does not light up red) and the modline vanishes as soon as you switch to another preset.

I would suggest that this is a usability bug which should be fixed. If a user adds a modline, I think it should be considered as a modification even if it's disabled and no parameter changes have been made. Or at least some kind of hint to the user should be displayed to avoid the confusion I experienced. Thanks!
Posts: 737
Joined: Fri Jan 31, 2014 5:31 pm

Re: SOLVED: modlines vanishing after being added

Postby TheOtherSupport@KMI » Thu Jul 20, 2017 8:31 am

I feel a bit like a broken record, but what is your OS? Any software issues need to be accompanied by the OS, or I can't troubleshoot effectively.

Return to “SoftStep Users' Help Exchange”

Who is online

Users browsing this forum: No registered users and 5 guests