12 Step Freezes

Get help from other 12 Step users
ramuji
Posts: 10
Joined: Fri Jun 07, 2013 11:41 pm

12 Step Freezes

Postby ramuji » Fri Sep 13, 2013 5:37 am

Hi. I've having trouble with my 12 Step freezing when sending a note. When it freezes, the 12 Step becomes unresponsive to all MIDI messages. The only way to reset the 12 Step is to unplug the power and then plug it back in again. Based on trial and error over the past week, it seems to freeze when the following 2 conditions are met:

1. The 12 Step is powered via the MIDI Expander.
2. The 12 Step is in Legato note mode.

If the 12 Step is powered by my Macbook's USB port, the 12 Step does not freeze even in Legato note mode.
If in Normal note mode, the 12 Step does not freeze even if powered via the MIDI Expander.

My setup (for live performance) is designed to have the 12 Step powered by MIDI Expander; providing power by computer is not a very attractive option.

Has anyone here had a similar experience, or can offer any suggestions/advice?

Thanks!
TheSupport@KMI
Posts: 726
Joined: Wed Jul 13, 2011 12:30 pm

Re: 12 Step Freezes

Postby TheSupport@KMI » Fri Sep 13, 2013 12:01 pm

Hmm, that seems odd.

How exactly do you have things connected when powering the 12 Step from the Expander?

When powered from the Expander, is the 12 Step also plugged into a computer via USB? If so, you should probably unplug the computer part — you shouldn't ever power the 12 Step from both the Expander and computer USB at the same time.
2, 3, 5, 13, 89, 233, 1597, 28657, 514229, 433494437, 2971215073
ramuji
Posts: 10
Joined: Fri Jun 07, 2013 11:41 pm

Re: 12 Step Freezes

Postby ramuji » Sat Sep 14, 2013 12:36 am

Thanks for the response. I'm also getting help via a support ticket, but the more help the better.

When powered via the Expander, I have the following connections:

12 Step "to Expand" -> Expander
Expander "Power" -> AC outlet on Power Pedal 2 Plus
MIDI In/Out ports connected to MIDI footboard controller (Gordius Little Giant)

This configuration works fine when the 12 Step is in Normal mode or Toggle mode. If I switch to Legato mode (or Legato in Hold mode), I can play one note and the 12 Step freezes immediately. Every time.
Powering the Expander via wall outlet gives the same results. I've also tried a different USB cable for power, but get the same results.
I've also reinstalled the firmware (A2) at least 4 times over the past 2 days, and the problem persists.
Freezing occurs whether I use my own settings or the factory settings immediately after a firmware reinstall.

When the 12 Step is powered by computer USB, there is zero problem; everything works as expected. A few times I've had both computer USB and Expander power plugged in, and the 12 Step worked as expected. The 12 Step freezes only when it is powered by Expander only.

I agree, it seems very odd. Any suggestions?
ramuji
Posts: 10
Joined: Fri Jun 07, 2013 11:41 pm

Re: 12 Step Freezes

Postby ramuji » Sat Sep 14, 2013 1:02 am

Ok, that last message where I described my connections led me to check the MIDI In/Out connections next.

When powered via Expander (computer USB disconnected):
If I unplug all MIDI connections between the Expander and Little Giant, the 12 Step does not freeze in Legato mode.
If I connect the Expander MIDI Out to the Little Giant MIDI In, the 12 Step does not freeze in Legato mode. 12 Step Note messages are sent normally to the Little Giant.
If I connect the Expander MIDI In to the Little Giant MIDI Out, the 12 Step freezes in Legato mode. The 12 Step responds normally to MIDI PC messages from the Little Giant until it freezes in Legato mode.

So, the problem appears to be somewhere in the MIDI path sending messages from the Little Giant to the 12 Step. But, why only in Legato mode?

Doing some further testing ...
ramuji
Posts: 10
Joined: Fri Jun 07, 2013 11:41 pm

Re: 12 Step Freezes

Postby ramuji » Wed Sep 18, 2013 1:25 pm

Update:

I've been discussing this issue with KMI Support via email (and not updating my test results here), but thought I'd share the latest development here in case others are experience the same issue.

Latest response from KMI Support:

"We just ran tests here in the office and confirmed the behavior you describe.
It appears you've found a bug in the firmware that will need to be corrected in an update.

We do have a revamp in the works to provide more robust uses for the 12 Step.
We've made a note to correct the bug you found as well.

I'll keep you updated."
utnut1
Posts: 2
Joined: Mon Feb 25, 2013 7:28 pm

Re: 12 Step Freezes

Postby utnut1 » Tue Oct 01, 2013 10:46 am

Hey, I would like to know how this turns out for you. I'm having some similar issues with my 12step freezing. I use a soft synth with a laptop (no hardware device), with Cantible as my DAW. However, it only freezes occasionally. The problem seems to come and go in bunches. I may use it for two gigs with no issue whatsoever. Then, the next gig it will freeze several times within a night. It never freezes on an audible note. Rather, when I step on a note/button in legato, the button led stays on and the board stops responding to any other presses. Only unplugging the USB cable and closing and re-plugging and re-starting Cantible will work. Sometimes I'm unable to close Cantible unless I unhook the USB cable first (tough during a gig)! I use it mostly in legato mode. I've pretty much eliminated my laptop as the culprit. There are no events in Event Viewer, no CPU or memory issues, no overheating issues, and I think I've eliminated vibrations from stage (rock band) as much as possible. I can only guess that it is either the 12step or Cantible or some combination. I wonder if scrolling through patches or stepping on several buttons quickly may also be related. Would like to know if a firmware update fixed your issue. I may try a firmware update, but I certainly don't won't to create more problems. Thanks!
pjefferson
Posts: 11
Joined: Fri Feb 15, 2013 10:39 am

Re: 12 Step Freezes

Postby pjefferson » Thu Oct 03, 2013 2:23 am

I have had this same problem when using mine and found the only way to resolve it was to power cycle the unit. I run mine directly connected to an iPad. Hope the fix is soon.

Also, curious about the major revamp and what it will do. I have found this pedal to be one of the most useful things I have purchased in quite a while and everyone who I show it to is totally intrigued by it. Hope the revamp comes out soon.
DenisLM
Posts: 6
Joined: Thu Jan 16, 2014 2:12 pm

Re: 12 Step Freezes

Postby DenisLM » Thu Feb 06, 2014 4:12 pm

+1 with the same problem with a 12 Step + Expander connected to a Korg Kross.
If I disconnect the midi in of Expander everything works just fine.
But I need this connected to receive the program changes from Korg... :?

Also running the firmware A2.

Any news about this case?
chrisg
Posts: 18
Joined: Sat Feb 02, 2013 2:49 pm

Re: 12 Step Freezes

Postby chrisg » Thu May 15, 2014 4:57 pm

I recently opened the editor for the first time in a while; had to make some changes to the presets for my setlist. As always, the 12-step turns on just fine, says A1 then goes to the chromatic preset and I'm good to go. But this time I opened the editor and it tells me I need a firmware update and so I do it and it does its thing, finishes; I do my thing, finish and all is hunky-dory. Then today I come here to the website, like I do every so often to see if there is anything new I need to know and I see this post. I had this problem about 2 months after I got the unit and KMI Support was on it right away and told me to reinstall the firmware and I did and the problem was fixed. Never froze again. Still hasn't. So I see this post and see some people are using firmware A2, when mine still says A1- even after I did the update. What's the deal A1, A2...what do they mean, does it matter? Should I worry? What was the update for anyway? Thanks!

Return to “12 Step Users' Help Exchange”

Who is online

Users browsing this forum: No registered users and 1 guest

cron