Page 1 of 2

Bugs with IOS 8.3?

Posted: Tue Jun 23, 2015 11:52 am
by kirkdickinson
I found several posts on the TalkBass.com forum about them having problems with IOS 8.x and newer with the 12-Step. I have 8.3 on all my devices. Have these issues been sorted out? I just ordered a 12-Step and really need it to work with IOS8.

Thanks,

Kirk

PS... Here is the text of that post:

OK, I updated my iPhone 5 to 8.02 and Animoog to 1.1.5 and the 12-step still isn't recognized! Bummer. CoreMIDI was upgraded in iOS 8 so I'm guessing that has something to do with it. My Korg nanoKey still works like a charm. Garageband also works fine with the nanoKey but not the KMI 12-step. If this doesnt get resolved there is no reason for me to own the 12-step :(

Later post to my question "Is it fixed?"
not to my knowledge. i sold my 12-step. good luck.

Re: Bugs with IOS 8.3?

Posted: Tue Jun 23, 2015 2:43 pm
by TheOtherSupport@KMI
12 Step works perfectly on iOS 8.3. Just updated my iphone to that version, and I can connect to Animmog with no issues.
People that are experiencing connection issues likely aren't powering the device properly.
i.e. before plugging it into the iPad/iPhone.

The issues haven't been sorted out, because it's likely there were no issues to begin with. If you end up having issues when you receive your unit, I'd be happy to help you troubleshoot.

Re: Bugs with IOS 8.3?

Posted: Tue Jun 23, 2015 7:33 pm
by kirkdickinson
Thanks for the reply. I hope to have it by the first of next week. Will I be able to run it with an iPod touch 5 with only the camera cable?

I have been excited to try this since I first read about it. I just hope I can manage this and the bass at the same time.

Kirk

Re: Bugs with IOS 8.3?

Posted: Tue Jun 23, 2015 8:42 pm
by TheOtherSupport@KMI
You won't be able to run the 12 step with only the Camera Connection kit. You will absolutely need an external power supply. Apple limits the amount of power available from their devices, and without proper power the 12 step won't connect to the iOS device.

Re: Bugs with IOS 8.3?

Posted: Wed Jun 24, 2015 3:57 am
by kirkdickinson
Sorry I wasn't clear in my statement, I know I need the power kit. I was hoping that I didn't also need to use both the midi expander and have iOS to midi device.

I actually will have the expander but for simple set ups was hoping not to use it.

Re: Bugs with IOS 8.3?

Posted: Sun Jun 28, 2015 5:30 am
by TheOtherSupport@KMI
There's no need for the MIDI expander when connecting to an iOS device.
yOu only need the camera connection kit, and a an external power source.

Re: Bugs with IOS 8.3?

Posted: Tue Jun 30, 2015 8:14 pm
by kirkdickinson
I have the camera adapter kit, I have hooked up everything is shown in the FAQ. When I go to My Animoog program. The 12 step is not an option available for an input source.

I can hook it up with the midi break out kit and an iPad to midi adapter. The adapter is immediately available to be selected as a midi source.

This is not a generic adapter it is an Apple adapter.

I have tried it on an iPad and I tried it on an iPhone I pod touch. Same results every time.

Any ideas what to try?

Re: Bugs with IOS 8.3?

Posted: Tue Jun 30, 2015 8:31 pm
by TheOtherSupport@KMI
Are you making sure to power the device externally via the Expand port?
It may need to be powered prior to connecting it to the iOS device.

Re: Bugs with IOS 8.3?

Posted: Wed Jul 01, 2015 4:49 am
by kirkdickinson
Yes. Powered externally. Connected, disconnected several times. Restarted Animoog. Restarted iPod. Tried iPad. Tried iPhone. I seem to be missing a step somewhere?

Re: Bugs with IOS 8.3?

Posted: Wed Jul 01, 2015 5:45 am
by TheOtherSupport@KMI
You need to power the 12 step FIRST, then connect it to the iOS device. That's pretty much the only thing you could be missing.
Have you refreshed the MIDI list in Animoog?
Have you tried a different App, or used a MIDI Monitor? https://itunes.apple.com/us/app/midi-mo ... 50746?mt=8

Try using a different USB cable. You're also sure that you'r plugging into the proper port labelled USB and not Expand?