XY mapping issues with CoMA, Sonar X3, and Alchemy [SOLVED]

Woolyloach
Posts: 10
Joined: Mon Feb 17, 2014 5:37 pm

XY mapping issues with CoMA, Sonar X3, and Alchemy [SOLVED]

Postby Woolyloach » Mon Feb 17, 2014 6:17 pm

Yes, I have read the manual and yes, I have watched the YouTube CoMA tutorials several times, so you know I tried this on my own before crying for Mommy.

I'm running Sonar X3 and have a single instance of Alchemy loaded. I hold the MODE button until all the LEDs flash. I go to Alchemy and turn on "MIDI Learn X". I then go to a slider and stroke down it, I see two center green LEDs light. I press MODE to turn CoMA off, and try the slider.. nothing.

Braking out my trusty MIDIOx, I see that the slider is still sending note on/off information. Erm, what? According to the manual and the tutorials, I should only see CC information... right?

Am I missing something? I'm no stranger to MIDI and normal control surfaces, but my QuNeo has succeeded in stumping me completely.

Ass assistance appreciated. For now, I'm going back to my QuNexus.
Last edited by Woolyloach on Sat Feb 22, 2014 9:29 am, edited 1 time in total.
Woolyloach
Posts: 10
Joined: Mon Feb 17, 2014 5:37 pm

Re: XY mapping issues with CoMA, Sonar X3, and Alchemy

Postby Woolyloach » Tue Feb 18, 2014 7:06 am

Ok, one long night, four beers, and 1/2 a cold pizza later, I did discover a few things:

- Sonar X3 needed to be told to route the QuNeo to Alchemy at the same time as my QuNexus was driving it

- I reset the QuNeo to all factory defaults and things worked better (got this one used from Musicians Friend, I should have factory defaulted the thing as soon as I got it out of the box, my fault here)

- Apparently sensors work in "drop" mode - take your finger off and the mapped control returns to zero. This is useful in some scenarios, but with Alchemys X/Y pads it's not really "expected behavior" to have them jump to zero when I let go

So at this point I'm satisfied that the QuNeo is actually "working as designed". I added my voice to the "hold vs drop mode" thread in New Features Request.

For now I'll just change my approach to the QuNeo and work with it "as-is". There's plenty here to keep me busy for ages..
TheOtherSupport@KMI
Posts: 705
Joined: Fri Jan 31, 2014 5:31 pm

Re: XY mapping issues with CoMA, Sonar X3, and Alchemy

Postby TheOtherSupport@KMI » Tue Feb 18, 2014 12:23 pm

The sensors don't behave in drop mode, but some values do. Like note, and pressure on the sliders, but location shouldn't jump back to zero on the sliders.

Alternatively you can map the pads to latch location while in x/y mode.

It sounds like you are mapping pressure form the sliders to Alchemy, which may lead to the jumping to zero behavior.
Woolyloach
Posts: 10
Joined: Mon Feb 17, 2014 5:37 pm

Re: XY mapping issues with CoMA, Sonar X3, and Alchemy

Postby Woolyloach » Wed Feb 19, 2014 5:51 am

I'm fairly sure it's that I haven't spent enough time with the editor - CoMA mode gets me halfway there, but I suspect I'm going to do some deep customization via the editor to get things working the way I'd like.

Not dissing on the device, I love it and I can find 1000 uses for it as-is, but it's not an out-of-the-box it-just-works thing for my application.

It is a blast to assign one of the rotary controls to some of Alchemys knobs and running my finger across it while playing.. get some interesting results.

I'm going to set aside a few hours this weekend to do nothing but play with the editor and see what I can do. The QuNeo is so flexible I can't see any reason (short of me being too stupid to own one) that I can't make it work.

And thanks for the reply - much appreciated!
TheOtherSupport@KMI
Posts: 705
Joined: Fri Jan 31, 2014 5:31 pm

Re: XY mapping issues with CoMA, Sonar X3, and Alchemy

Postby TheOtherSupport@KMI » Wed Feb 19, 2014 12:53 pm

No problem.

To get the most out of the QuNeo you definitely need to spend some time with the editor, and thinking about what exactly you want to do with it. In that sense it's not an "out of the box: type of controller, which I think is a good thing. It force the artist to really evaluate what they want to control in their software, and how they want to control it.

Best of Luck!
Woolyloach
Posts: 10
Joined: Mon Feb 17, 2014 5:37 pm

Re: XY mapping issues with CoMA, Sonar X3, and Alchemy

Postby Woolyloach » Sat Feb 22, 2014 7:34 am

I'm starting to get somewhere, finally!

I did have to sit down and think about how I wanted to use the QuNeo.. being an ambient musician, my initial idea was to just bind all the controllers to various VST parameters, but now.. I'm reconsidering that.

I'm likely to set up some of the pads to trigger samples, the sliders to control track parameters (volume/pan) and some controls as X/Y for both Alchemy and my Wavestation Legacy.

This deice is definitely the most flexible MIDI controller I've ever had my mitts on!
Woolyloach
Posts: 10
Joined: Mon Feb 17, 2014 5:37 pm

Re: XY mapping issues with CoMA, Sonar X3, and Alchemy [SOLV

Postby Woolyloach » Sat Feb 22, 2014 9:35 am

Ok, this took some deep thought, research, MIDI-Ox to track the MIDI flow, and a TON of coffee (uurp) - BUT IT WORKS NOW!

I ended up using the sliders rather than the rotaries for X/Y as it gave me better control over both axes in Alchemy.

What I did:

- Turn OFF note transmit
- Turn OFF pressure transmit
- Velocity fixed at 1 (not sure if needed)
- CHOOSE LOCATION CAREFULLY

That last item is the critical one.. Alchemy will NOT recognize just any arbitrary location, some are flat-out ignored! I used trial-and-error to find locations that worked, but once I had a list I got the QuNeo running the X/Y pads and 4 user assignable knobs, so I'm pretty darn happy.

I left the pads as note generators because between the sliders and pads, the QuNeo is a great input device/controller for building up ambient tracks.

So, all's well that ends well. :D :D
Woolyloach
Posts: 10
Joined: Mon Feb 17, 2014 5:37 pm

Re: XY mapping issues with CoMA, Sonar X3, and Alchemy [SOLV

Postby Woolyloach » Mon Feb 24, 2014 9:10 am

As a postscript: using the same approach I also have the QuNeo running the joystick on my Wavestation Legacy VSTi. I'm very, very happy now! :D :mrgreen:
TheOtherSupport@KMI
Posts: 705
Joined: Fri Jan 31, 2014 5:31 pm

Re: XY mapping issues with CoMA, Sonar X3, and Alchemy [SOLV

Postby TheOtherSupport@KMI » Mon Feb 24, 2014 11:35 am

Glad you got up and running!

The QuNeo is definitely one of those devices where you need to spend some time with it in order to really get the most out of it.

Return to “QuNeo General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest

cron