Amplitube synching

Get help from other SoftStep users.
mehrdadp
Posts: 18
Joined: Sun Jun 03, 2012 1:34 pm

Amplitube synching

Postby mehrdadp » Tue Dec 17, 2013 3:28 pm

I have assigne a couple of buttons on my softstep to turn on/off a couple of effects in IK amplitube, namely wah on/off and guitar distortion effect on/off. This works just fine and in fact the lighting a on the softstep synch well with current status of the effect in Amplitube (running within live 9).
However, the very first time after I open my set I have to push these two buttons on the softstep to connect/synch with Amplitube. This becomes frustrating if one has to do a onetime touch on these keys to get it in tune with Amplitube effects.
Is there anyway to have amplitube effects on/off buttons and the two corresponding softstep keys to be always in tune, that is not to be necessary to push SS buttons at the beginning of the file openning in order to get them synchex?

Thank you very much.
MacBook pro, OS 10.10.5, Apple Duet, Ableton Live 9, SoftStep 1 in hosted mode, Amplitube 4.
TheSupport@KMI
Posts: 726
Joined: Wed Jul 13, 2011 12:30 pm

Re: Amplitube synching

Postby TheSupport@KMI » Tue Dec 17, 2013 6:37 pm

When you first open things up, do the Amplitube effects load up enabled (ON)? And are you using the toggling function of the SoftStep?

If both of the above are true, then I believe you have to press twice because the SoftStep's toggles default to OFF. The first time you press the SoftStep key it will turn the toggle on, but since the effect in Amplitube is already on, it seems like nothing happens. Then the second time you press the key it will turn the toggle off, which then turns the effect off.

So if this is the case (again, I don't know the specifics of your project/setup), there are two options:

1. Make the Amplitube effects default to OFF when loaded
2. Make the SoftStep toggles default to ON

Number 1 would probably be the best if it's possible (I'm not much of an Amplitube expert so I don't know the exact details of how to do this). Number 2 is possible, but the modline setup can be a little annoying — and will be different if you are in Hosted mode or Standalone mode (let me know which mode you're in).

Also, what scene are you using with your SoftStep? One of the default scenes or one you made yourself? What do your modlines look like? Are you using notes or CCs to toggle the effects?
2, 3, 5, 13, 89, 233, 1597, 28657, 514229, 433494437, 2971215073

Return to “SoftStep Users' Help Exchange”

Who is online

Users browsing this forum: No registered users and 4 guests

cron