Windows 10

Dallon426
Posts: 22
Joined: Wed Jun 20, 2018 1:31 am

Windows 10

Postby Dallon426 » Sun Jun 24, 2018 7:35 pm

I keep getting dropouts and fuzzy audio. Samplerate won't stay at 16bit 44.1. I've tried every setting imaginable and nothing will work. Can't even play mp3 files.
Is this not supported for Windows 10 64bit? If not are you guys working on something? Pretty bummed, I just bought this only to discover it doesn't function properly I read that it does function with Windows 8. I didn't see anything on the site stating which version of Windows.
TheOtherSupport@KMI
Posts: 721
Joined: Fri Jan 31, 2014 5:31 pm

Re: Windows 10

Postby TheOtherSupport@KMI » Mon Jun 25, 2018 6:39 am

It works with Windows 10 for sure. We've done plenty of testing, and I've used it on Windows 10 pretty frequently for testing/troubleshooting.
What are your buffer settings?
Sample rate can be set in some applications and the advanced tab of the sound settings in the OS.
Dallon426
Posts: 22
Joined: Wed Jun 20, 2018 1:31 am

Re: Windows 10

Postby Dallon426 » Mon Jun 25, 2018 2:07 pm

I'm using maschine. Sample rate is 44.1 and anything under 512 buffers starts to sound distorted and robotic.
Also, like I said I can't get Sound to play on YouTube videos or mp3 via Windows Media player. Every other interface I've tried works. This is the first one I've come across that has given me troubles. Also the audio cable that came with the k-mix won't work. K-mix will not connect with the cable. I tried two others I had sitting around and they worked. What's odd is I tested the cable that came with k-mix on my phone and.it works. It works on wall.outlet and while connected to the PC. It doesn't work while connected to the k-mix. It powers the unit but is not recognized as a sound source. I have an ASRock z370 itx Mobo and not sure if that's the problem. Strange.
Regardless though, on a zoom UAC I can get buffers as low as 32 with no issues running standard projects. Rme Babyface is the same but performs better. So I assure windows is not the problem.
Dallon426
Posts: 22
Joined: Wed Jun 20, 2018 1:31 am

Re: Windows 10

Postby Dallon426 » Tue Jun 26, 2018 12:22 am

Can you guys post a video of this unit actually working with Windows 10. Playing YouTube, mp3 and working in a daw such as Cubase or machine? Thanks
TheOtherSupport@KMI
Posts: 721
Joined: Fri Jan 31, 2014 5:31 pm

Re: Windows 10

Postby TheOtherSupport@KMI » Tue Jun 26, 2018 5:46 am

The device works on Windows 10 and has for quite awhile. Not sure what the issue is with your particular system, and I'm not sure what a video would accomplish.

Try uninstalling and reinstalling the driver.

The issue with web browsers, media player etc. may be a sampling rate thing. The K-Mix defaults to 96k, which quite a few windows applications don't like, so you have to get the K-Mix to default to 44.1 by messing around in the sound preferences.
Dallon426
Posts: 22
Joined: Wed Jun 20, 2018 1:31 am

Re: Windows 10

Postby Dallon426 » Tue Jun 26, 2018 3:44 pm

Can't you guys update the driver to default to 44.1?
Why couldn't you guys write in the software a function which will allow us to change the sample rate within the software and allow the use to select a default samplerate?
Last edited by Dallon426 on Wed Jun 27, 2018 7:20 am, edited 2 times in total.
Dallon426
Posts: 22
Joined: Wed Jun 20, 2018 1:31 am

Re: Windows 10

Postby Dallon426 » Wed Jun 27, 2018 4:08 am

Here, take a look. I went out and bought a hi grade usb 2.0 cable since the one that was supplied didn't work.

I cannot get the unit to play audio other that via my daws (maschine and cubase) So please, explain to me what is going on. It is not my system ;)

Also I still cannot get the K-mix to play under 512 MS buffer settings, set to standard. I said it before and I will say it again, you guys have a great idea here but maybe you packed too much into it and lost focus on the most important part (the audio interface) cause as far as I can tell it is not compatible with windows 10 at all. I tried many cables, uninstalled the driver, reinstalled, etc. I am no rookie either, been at this a long time. It might be time you guys look at things on your end.

3.JPG


2.JPG


1.JPG
Dallon426
Posts: 22
Joined: Wed Jun 20, 2018 1:31 am

Re: Windows 10

Postby Dallon426 » Wed Jun 27, 2018 4:27 am

Okay got youtube to play and mp3's

This is not explained and I literally stumbled upon it while trying everything I could think of t get the K-mix to function. Note, I have never needed to do this with ANY interface I have used.

I will post pictures for anyone having issues. You have to select the k-mix and then select configure. Then change the outputs to stereo.


1.JPG




2.JPG



Also if I shut the unit off I have to restart the computer in order for the soundcard to be recognized. Again an issues I have never had with any other soundcard.


no.JPG
TheOtherSupport@KMI
Posts: 721
Joined: Fri Jan 31, 2014 5:31 pm

Re: Windows 10

Postby TheOtherSupport@KMI » Thu Jun 28, 2018 5:12 am

So what was the speaker configuration set to before you switched it to Stereo? That's never been an issue we've heard of before, so maybe it did have something to do with your system after all...

This is our first audio device, and we don't have quite as much experience with windows usb audio drivers as say, Presonus does, but saying that the product is totally incompatible with Windows 10 is not an accurate statement. We have plenty of happy Windows users out there.
Dallon426
Posts: 22
Joined: Wed Jun 20, 2018 1:31 am

Re: Windows 10

Postby Dallon426 » Thu Jun 28, 2018 6:50 am

I understand that this is your first experience however perhaps more testing should have been done and maybe even a manual for install with windows. Because it clearly is not the same. I finally got this to work after troubleshooting it myself for the last three days.

So let's discuss some things so that in the event of an update or any future interfaces, the process will be less strenuous for a customer. The lack of knowledge and support that you guys have with windows is frustrating from a customer perspective. So I will create a new thread with all the steps I have used in order to get this to work "decently" There are still some things that are not quite clear to me.

First being the interface sometimes loses connection when starting the k-mix editor and then I have to restart my system. Then sometimes the soundcard is not recognized. So, I then have to shut off the K-mix, shut down the computer and then turn on the K-mix FIRST, then the computer and cross my fingers.
This has happened to me several times, just today. And I assure you it is not the cable because the one that was supplied did not work so I bought a high end USB 2.0 cable.

I have a few questions.

Why is there no installer for the k-mix editor?
Why is there no ability to change the samplerate within the USB K-mix audio control panel? That would make things easier from the jump. Every software I have used since 2000 has had this feature within windows.
Why does the K-mix editor not realize the current version of firmware?
Why isn't the unit recognized if I turn it on AFTER I start the PC and Boot into windows? I asked that same question here, so let's see what the community thinks. https://www.gearslutz.com/board/music-c ... power.html

I think this could be a fantastic interface, but on windows it does need some work and I hope it is something that you guys take into consideration.
I will be doing further testing and asking more questions, I apologize if I came across rude but I was in a state of frustration because I have never had such a hard time setting up an interface. I want to help make this a better product because it does have the potential. Cheers,

Dallon

Return to “K-Mix General Discussion”

Who is online

Users browsing this forum: No registered users and 0 guests